Get in touch
Back
Resolved

Experiencing availability issue due to service degradation at CloudFlare

Started 18 Nov at 03:55pm IST, resolved 18 Nov at 04:44pm IST.

US Application
Resolved

A fix has been implemented by Cloudflare and services are back to normal.

Posted 18 Nov at 04:44pm IST.
Updated

We are still observing issues with Cloudflare. We are closely monitoring the situation.

Posted 18 Nov at 04:29pm IST.
Created

We are investigating availability issue with Staircase application.

Posted 18 Nov at 03:55pm IST.